на главную

Как использовать обработку в своих разработках?


В обработку добавлена ДемоФорма, которую можно назначить основной и посмотреть как построить свое облако.


Далее привожу модуль ДемоФормы:

//перед открытием проверим что вообще возможен HTML документ на форме
Процедура ПередОткрытием(Отказ, СтандартнаяОбработка)
Если ЭлементыФормы.Найти("ПолеHTMLДокумента") = Неопределено Тогда
Сообщить("Возможностей вашего компьютера недостаточно для отображения html-документов.
|Запуск обзора конфигурации невозможен.
|Для отображения html-документов необходимо установить Microsoft Internet Explorer 6.0 или выше.");
Отказ = Истина;
КонецЕсли;
КонецПроцедуры


//обработка события нажатия на ссылку облака
Процедура ПолеHTMLДокументаonclick(Элемент, pEvtObj)
Сообщить("Нажата ссылка с ИД="+pEvtObj.srcElement.id);
КонецПроцедуры


Процедура КнопкаВыполнитьНажатие(Кнопка)
МассивСтруктур=Новый Массив;
МассивСтруктур.Добавить(Новый Структура("Вес,Представление,ИД",1,"Тест 1","ТЕСТ1"));
МассивСтруктур.Добавить(Новый Структура("Вес,Представление,ИД",2,"Тест 2","ТЕСТ2"));
МассивСтруктур.Добавить(Новый Структура("Вес,Представление,ИД",3,"Тест 3","ТЕСТ3"));
МассивСтруктур.Добавить(Новый Структура("Вес,Представление,ИД",4,"Тест 4","ТЕСТ4"));
МассивСтруктур.Добавить(Новый Структура("Вес,Представление,ИД",5,"Тест 5","ТЕСТ5"));
// Функция СоздатьСтраничкуОблако(МассивСтруктур,Разброс=4,ФильтрСтрока="") Экспорт
// определена в модуле обработки и используется для построения HTML страницы с облаком
//
// Пармаетры:
// МассивСтруктур - массив элементами которого являются структуры с полями
// Вес - число, вес элемента
// Представление - строка, выводится на экран
// ИД - строка без пробелов, идентификатор элемента облака,
// возвращается при нажатии
// Разброс - число, не обязательный параметр, возможные значения 2,4,8, определяет вид облака
//
// ФильтрСтрока - строка, не обязательный параметр, если установлен, то элементы в представлении
// которых встречается данная строка (case insensitiv) подсвечиваются желтым цветом
//
Стр=СоздатьСтраничкуОблако( МассивСтруктур, 4, "5" );
ЭлементыФормы.ПолеHTMLДокумента.УстановитьТекст(Стр);
КонецПроцедуры



    E-mail:alex собака mut.ru   ICQ:93248848